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Freeplane is a program for

creating mind maps. The

program is versatile enough to fit

anyone's mapping style. You can

make the maps as simple or as

complex as you need for your

application. Freeplane is available

in the Ubuntu Software Center or

online at their web page,

https://www.freeplane.org/wiki/in

dex.php/Main_Page.

WHAT IS A MIND MAP?

A mind map is a visual diagram

for organizing ideas and

information. Use a mind map to

brainstorm a new idea, create a

process, or organize your

thoughts. A mind map can help you

keep notes during a lecture and

see patterns you might otherwise

miss. I 've used mind maps through

the years to write stories and

articles, and create the processes

for programs. I also used mind

maps to create teaching and

training curricula. Yes, I know other

tools exist for doing these things,

but a mind map gives me

something other tools don't. With

a mind map, I can see the entire

program structure and functions.

Other tools don't give me this

broad overview. Being able to see

the entire thought process allows

me to see connections I would

otherwise miss.

The basic structure of a mind

map starts with a central topic.

This is the idea, class, process, or

topic you are mapping. From the

central topic, the map branches

into several subtopics related to

the topic. The subtopics can branch

out to other child topics, and those

child topics out to other child

topics. The branches can go as

deep as needed for the topic.

INSTALLATION

You can download Freeplane

from the Ubuntu Software Center.

I 'm starting with the latest

download version, 1 .6.1 0. While

you can follow along with the

version available in the Software

Center, I will discuss new features

found in 1 .6. You can download

version 1 .6 from the Freeplane

home page,

https://www.Freeplane.org/wiki/in

dex.php/Main_Page. Freeplane is a

Java program. If you are running

the latest Java runtime, you should

have no problems running

Freeplane.

PROGRAM WORKSPACE

The program has a standard

layout with the menus and

toolbars at the top, and a

workspace at the bottom. On the

left-hand side, you can pull out an

Icons toolbar, and on the right-

hand side, you can pull out the Tool

Panel. By default, you can pop up

the Note panel at the bottom. In

the Preferences, you can change

where the Note panel docks.

The menu bar sits below the

https://www.freeplane.org/wiki/index.php/Main_Page
https://www.Freeplane.org/wiki/index.php/Main_Page
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title bar. The menus give you

access to the program's

commands.

The program has several

toolbars. The main toolbar shows

by default. The main toolbar gives

you access to save options and

common formatting actions. The

Filter toolbar allows you to filter

what nodes of the map show,

making it a handy search tool. The

F-Bar shows the actions assigned

to the F-Keys. You can customize

the actions assigned to the F-Keys.

The Icon toolbar gives you a set of

icons for marking nodes in your

maps. And the status bar sits at the

bottom of the window. The status

bar displays information about the

current map or selected node. The

Filter, F-Bar, Icon, and status bars

hide by default, but you can

activate them through the menu

View > Controls.

The workspace in the middle is

where you will build your map. You

can have many maps open at one

time, and each one displays a tab

at the top of the workspace.

Scrollbars hide by default, but you

can show them using the View >

Controls menus. You can click and

drag on a blank space in the map

area to move the map around. The

wheel on your mouse will scroll the

map up and down. Hold the SHIFT

key and scroll the mouse wheel to

move the map left and right.

YOUR FIRST MIND MAP

Enough talk! Let's make our

first map. If you haven't already

done so, install and open

Freeplane. Create a new map by

selecting File > New Map from the

menus. In the template dialog,

select the standard template. In

the 1 .6 version, the name is

standard-1 .6.mm. This creates a

new map with a root topic in the

center of the screen. Type in a

name for your topic like "My First

Map." Press the Enter key to save

the name.

To create subtopics for your

main topic, press the Insert key on

the keyboard. Nodes that are one

level deeper than the current node

are called child nodes of the

current node. Type the text for the

subtopic, and press the Enter key.

Create more subtopics by pressing

the Enter key. Nodes on the same

level are called siblings in
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Freeplane. Create several

subtopics by pressing Enter and

typing in some text.

Now, let's create child nodes of

a subtopic. Select one of the

subtopics and press the Insert key.

Type a name for the new node.

Press Enter to create siblings of

the new node or Insert to create a

child of the new node.

Branch out as far and using as

many nodes as you need. The

depth of your map is only limited

by the needs of your mind and

topic.

Next time we will look at some

of the core elements of Freeplane,

and do more with our map.

As I go through this series, I will

explore the capabilities of

Freeplane and the world of mind

mapping. I will look at the

possibilities and benefits of mind

mapping. If you've never used

mind maps before, I encourage you

to join us for this series. It may

change the way you process

information.

Elmer Perry is a technical support
rep for an international keyless
access company. He enjoys writing,
woodworking, and technology. He
lives in Leicester, NC with his wife.
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One of my favorite uses for

mind maps is brainstorming.

The idea behind brainstorming is

to write my ideas down on paper

or screen. I start with the subject

as the root topic, create the first

subtopic, and then I 'm off. I type in

the idea and press enter twice to

create the next. I will create

branches off the subtopic, but I

don't branch often. My goal is to

get all the ideas down, not develop

them. Usually, I brainstorm with a

stop time in mind. Whether the

time is 5 minutes or 1 5 minutes,

the clock forces me to focus on

writing my ideas down. I don't have

time for distraction. Once the time

is up, I can look at the big picture

of ideas. I will see relationships

between ideas or notice one idea is

actually the child of another. An

order or process begins to

develop. If I did this on paper, I 'd

have to redraw the whole map.

With Freeplane, I 'm able to move

the nodes around and reorder

them. This is a great time saver.

Today, we'll look at how Freeplane

lets us organize and manipulate

nodes.

SCROLLING

As your map grows, you will

want to zoom in on different

sections of your map. Once you

zoom in, scrolling the map

becomes important. Click and drag

a blank spot in the workspace to

move the map around. If you have

a scroll wheel on your mouse, spin

the wheel to move up and down.

The SHIFT key + the mouse wheel

moves left and right. If the

scrollbars are visible, you can scroll

with them. From the menu bar,

View > Controls > Scrollbars hides

and shows the scrollbars.

ZOOMING

To zoom in and out on your

map, hold CTRL + the mouse

wheel. From the keyboard, ALT +

up arrow zooms in, and ALT + down

arrow zooms out. When you need

to view the whole map, you can use

the menu bar View > Zoom > Zoom

to fit to page. You can also select

the zoom percentage from the

drop-down box in the main toolbar.

SELECTING NODES

To select a node, hover over it

for a few seconds. Once you have

the node you want, you can hold

the SHIFT key to lock the selection.

The selection of the node by

hovering requires you to pause

over the node. After the selection,

you can move across other nodes

as long as you don't pause. The

selection only changes when you

pause over another node. The

selected node is highlighted in

your systems default highlight

color.

You can select many nodes on

the same level and branch using

the SHIFT key. Select the first

node, then, while holding the

SHIFT key, select the second node.

This selects all the nodes between

the two nodes. You select non-

sequential nodes and nodes in

different branches using the CTRL

key. Hold the CTRL key while

clicking the nodes.

Use the arrow keys to move

around the map without having to

grab the mouse. The up, down,

left, and right keys work in the way

you would expect them to. Holding

down the SHIFT key allows you to

select many nodes as you move

around the map. CTRL + A selects

all the nodes in the map. Press the

ESC key to jump to the root node.

MOVING NODES

Ideas rarely comes in the

correct order, and you need to

move and rearrange the nodes in a

map. Freeplane lets you move

nodes through the mouse and the

keyboard.

You can move a node by the

drag and drop method. When you

drag and drop a node onto another

node, you get gray highlights at
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the top or on the child end of the

node. To insert as a sibling above

the node, drop the node on the

top gray highlight. If you drop on

the end gray highlight, Freeplane

adds the node as the last child of

the node. Hold down the CTRL key

to make a copy of the node instead

of moving it. You can drag and

drop to the left and right side of

the root node. This allows you to

balance the two sides of the map

when needed.

Sometimes, you want to set a

node off by itself. You can move a

node away from its siblings by

hovering over the parent

connector end. An oval will appear.

This oval is the move handle. Click

and drag to move the node to a

new location.

From the keyboard, CTRL + the

up/down arrows move the nodes

up and down among its siblings.

CTRL + the left/right arrows

promote and demote the node by

one level.

FOLDING/UNFOLDING

NODES

When working on sections of

the map, it helps to collapse or

fold the children of other nodes.

To fold the children of a node,

hover over the connection point

for the nodes. A circle with a minus

(-) will appear. Click on the circle to

fold (or hide) the nodes. When a

node's children are folded,

Freeplane marks the node with a

small circle on the child side. This

shows the node has hidden

children. You can expand or unfold

the node by hovering over the

circle. A larger circle with a plus (+)

will appear. Click this circle to

unfold or show the child nodes.

With a node selected, you can use

the spacebar to fold and unfold

the children. For more refined

control, buttons on the toolbar

allow you to fold/unfold one level

or all levels. These options are also

available in menu Navigate > Fold.

CORE TEXT AND NODE

DETAILS

The core text of the node is the

main text you enter when you

create the node. To see the area

for the core text, select the menu

Format > Node Core > Bubble. This

places a bubble around the core

text. To edit the core text, press

the F2 key. To replace all the

content of the node with new

information, start typing with the

node selected. If you need to break

the core text into many lines, you

can use the SHIFT + ENTER key

combination. You can edit the core

text in an editor dialog using the

ALT + ENTER key combination. We

will discuss the editor in a later

article.

The node details is extra

information about the node. The

text is placed below the node with

a triangle to the left side. Clicking

on this triangle shows and hides

the node details. From the

keyboard, ALT + F2 hide/show the

details. Press F3 to edit the node

details. You can change the details

text in an editor dialog by pressing

CTRL + F3.

Freeplane doesn't expect you

to get things perfect the first time.

In fact, it allows you to drag the

nodes around as needed. Whether

you prefer the mouse or the

keyboard, Freeplane allows you to

quickly change your map. In my

next article, I will present the 7

guidelines for mind maps from

Tony Buzan, and we will explore

the Tool Panel.

Elmer Perry is a technical support
rep for an international keyless
access company. He enjoys writing,
woodworking, and technology. He
lives in Leicester, NC with his wife.
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Tony Buzan introduced the term

"mind map" during his BBC TV

series Use Your Head in the 1 970's.

Buzan was a popular psychology

author. Yet, the use of radial

diagrams to display information

had been around for centuries.

Buzan introduced the world to his

approach and set rules for the

creation of mind maps. In his book

Mind Map Handbook

(https://www.goodreads.com/boo

k/show/31 1 8034-mind-map-

handbook), Tony outlines 7 steps

to making a mind map:

• Start in the center of a blank

page.

• Use an image or picture for your

central idea.

• Use colors throughout.

• Connect your main branches to

your central image, and connect

your second and third-level

branches to the first and second

levels, etc.

• Make your branches curved

rather than straight-lined.

• Use one key word per line.

• Use images throughout.

I would add an eighth rule:

customize the map to meet your

needs. When using other

diagramming methods, strict rules

confine how you can build your

map. With mind mapping, you are

free to give your own meaning to

symbols, codes, and groups.

Freeplane takes care of the

connections between nodes by

default. But, let's look at how you

can modify the nodes and lines to

make them mean something more

to you. In particular, how you can

change the colors, shape, and text

of the nodes and lines to develop

your coding system.

THE TOOL PANEL

The Tool Panel gives you access

to the properties of the individual

nodes. To open the panel, press

ALT+P on your keyboard, or from

the menu bar, View > Controls >

Tool Panel. You can also select the

arrow on the right edge of the

window. The Tool Panel docks to

the right side of the window. The

Tool Panel divides into sections

related to the different properties.

NODE STYLE

The node styles allow you to set

the node to a predetermined style.

We will discuss styles in a later

article. These settings are disabled

by default.

The first drop-down box applies

the level styles. Levels are how far

the node is from the root node.

The ‘for non leaf nodes’ sets the

level style on all nodes that are not

at the end of a branch. You can

think of nodes at the end of a

branch like leaves on a tree. These

are the leaf nodes. The other

choice is for all nodes. This option

includes the leaf nodes.

The Automatic edge color drop-

down box sets the edge coloring

for the nodes. When you select for

branches, each branch uses a

different color of lines. Select for

levels to make each step away

from the root node a different

color. When you select for

columns, you get an effect like for

levels, but the column is the

position rather than the level. You

can grab a node and move it into a

new column without affecting its

level. If you select on branch

creation, each new branch from

the root node gets a new color.

The Edit edge colors button

activates when you select an

Automatic edge color other than

Disabled. Clicking the button

opens a dialog window displaying

the different color levels. Click the

level swatch to open a color

selection dialog. Select a new color

for the level and click the OK

button to change the color for the

selected level. Use the up and

down arrow buttons to move the

levels up and down in the

hierarchy. The X button removes

the selected level color, and the +

button inserts a new level color.

The default number of levels is 1 1 ,

but I have added 50 without the

https://www.goodreads.com/book/show/3118034-mind-map-handbook
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program complaining. In most

cases, you will rarely go more than

1 1 levels deep in your mind maps,

except for the rare case of a very

large map. But, if you are creating

a different color for each branch,

you could soon need more than 1 1 .

The Style drop-down box lets

you select a predefined node style

for the node(s) . We will talk more

about predefined styles in a later

article. For now, know that you can

select them here. The conditional

styles are also another topic of

another article.

COLOR OF WHOLE CORE

The color section gives you two

swatches. One for the text and the

other for the background. Clicking

the swatches brings up a color

dialog where you can select the

color you want. These colors affect

only the currently selected nodes.

Always make sure you select

contrasting colors.

NOTE: The Core text section will

be an article on its own.

NODE SHAPE

The Node shape section is

where you manipulate the

geometry of the node. Most of the

shapes are self-explanatory. The

fork shape is the traditional mind

map underlined node style. Most

child nodes in the default template

are fork nodes by default.

When you select the as parent

shape, the node will follow the

shape of its parent node.

Combined is a special node. When

you expand the children of a

combined node, the node takes

the shape of a fork. When you

collapse the children, the node

takes the bubble shape.

The Horizontal margin and

Vertical margin set the distance

from the core text to the node

border. You can select a unit of

measure of pixels (px), inches (in) ,

millimeters (mm), centimeters

(cm), and points (pt) . These units

are available for any settings using

measurements.

The Uniform checkbox adjusts

the height of the node to match

the width of the node.

The Min node width and Max

node width are the minimum and

maximum widths of the node. The

widths do not include the margins.

The margins add to these settings.

The default max width is 1 0 cm.

The Child gap sets the distance

between the parent and its

children.

NODE BORDER
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The Node border section allows

you to change the width, style, and

color of the border around the

core text.

You can define a width using

the Line width spinner control and

the drop-down list to select the

measurement type. If you want the

border the same as the edge

coming from its parent node,

check the box Use edge width.

Select the Use edge line type to

make the border line the same

type as the line leading up to the

node. The Border line type drop-

down list lets you select a

different line style. Your choices

are solid, short dash, long dash,

dots, and dot-dash.

For the border color, you can

check Use edge color. Otherwise,

you can click on the Color swatch

and select a color from the color

dialog.

FONT OF WHOLE CORE

The Font of whole core section

allows you to change the family,

size, and styling of the core text

font. Remember this affects only

the core text and not the details

text. To change the details text,

you edit it in the editor dialog.

From the Font family drop-

down list, you can select the font

family you want. The list shows the

fonts installed on your computer.

Select the size of the font from

the Font size drop-down list. The

size list box is a combination

list/text box. You can select the

size from the default sizes in the

list, or type in a nonstandard size.

Check the boxes for Bold or

Italic to apply those styles to the

text.

The Text alignment drop-down

list sets the alignment for the text.

By default, the nodes are the

width of the text they contain,

hiding the alignments’ effect. The

alignments appear when you have

a fixed-width node, or the node

contains multiple lines of text. To

create a fixed-width node, set the

minimum and maximum width to

the same value.

The Hyperlink checkbox

underlines the node text like a

hyperlink. This works only when

you have a hyperlink set to the

node. We will cover hyperlinks in a

later article.

ICONS

In the Icons section, you can

change the size of the icons in the

node. Use the spinner box to set

the numeric size, and the drop-

down list to select the

measurement type. Icons add

visual clues to the nodes.

Increasing or decreasing the size

can influence the prominence of

the clue. Often the icon itself is

more important than the size. Yet,

if you want to use an icon as the

image for your central node,

increasing the size is a must.

EDGES

Edges are the lines connecting

child nodes to their parent. You

can change the width, line type,

style, and color of a node's edge.

By modifying the edges, you can

create a visual clue to the level,

meaning, or branch of a node. In

the default template, each branch

has a different color edge. As you
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read earlier, you can change this to

give a different color for each

level, branch, or column. You can

also disable automatic colors.

The Edge width is set using the

spinner box. The number here is a

scale rather than a measurement

amount.

To change the type of line used,

select from the Edge line type

drop-down list. The types are a

solid, short dash, long dash, dot, or

dot-dash line. You can use the line

types as a code for different

relationships between the node

and its parent. For example, use a

dashed line to show a hidden or

temporary relationship. The choice

is yours.

The Edge style controls the way

the line is created. There are 6

different edge styles. The default

style is the Smoothly curved

(bezier) . This best fits the

suggestion of a curved rather than

a straight line, but you can make a

case for straight lines too. If a

straight line makes sense to you,

then the Linear style gives you a

straight line from the parent to the

node. Another form of a straight

line is the Horizontal style. This

style creates edges with sharp 90

degree angles. Hide edge does not

display an edge between the

parent and child node. For a

unique touch, use the Sharply

curved (bezier) or Sharp linear

styles. The Sharply curved (bezier)

is like the smoothly curved except

the curves are tighter. If you

increase the width, the edge

becomes tapered from parent to

child. For the Sharp linear style,

you need a width greater than 0.

The style creates a straight line

tapered at the parent end and

comes to a point at the child end.

Clicking the swatch for Edge

color displays a color dialog. Select

the new color for the node's edge

and click OK. The new color will

override automatic color settings.

CLOUDS

I will cover clouds and what

they are in an article on grouping.

For now, know you can change the

Cloud color and Cloud shape here.

The four shapes are Arc, Star,

Rectangle, and Rounded

Rectangle.

Tony Buzan gave us 7 guidelines

for creating mind maps. Freeplane

allows you to apply these

guidelines as well as break them.

The flexibility lets you create your

own unique style of mind mapping.

For me, mind mapping is not about

following guidelines but finding

what works for you. Tony's

guidelines are a starting point.

Mind maps allow you to create

associations between objects and

ideas. As we continue learning

about Freeplane, we'll discover

more ways to create associations.
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When you learn or create,

associations speed up the

process. By associating something

known with something new, you fix

the idea in your mind. You can take

the new idea and associate it with

another idea, creating a chain of

ideas. Many of the great thinkers

of history used association in their

work. One most people are

familiar with is Leonardo da Vinci.

In his work, he created pictures,

codes, and lines. These "doodles"

created associations between

ideas.

Mind maps let you develop

associations through their

connections between nodes. But

connections are not always direct.

An idea in one branch could

associate with an idea in another

branch. Or a portion of a branch is

more important than the rest. You

could find a group of sibling ideas

that lead to another idea by their

association. In Freeplane, you can

create these connections through

clouds, connectors, and summary

nodes.

CLOUDS

Clouds group a node and its

children, grandchildren, etc. You

can use the cloud to emphasize a

certain section of a branch by

creating a border around the

nodes. The cloud surrounds the

node and those attached to it

down the branch until it reaches

the leaves. The cloud will enclose

any nodes added to the cloud's

nodes.

To create a cloud, you select the

node where you want the cloud to

begin. On the keyboard, you use

the keyboard combination CTRL +

SHIFT + B. The cloud will surround

all the nodes connected to the

selected node. You can add a cloud

through the menus using Edit >

Add/Remove Cloud. The menu

item is also available in the right-

click context menu. The main

toolbar has a Cloud button, too.

Repeating the action on the node

will remove the cloud. If you select

a node inside a cloud, you can

create a cloud inside a cloud.

By default the shape of the

cloud is the Arc style, creating the

classical idea of a cloud. You have

other options for the cloud shape.

You can select from Arc, Star,

Rectangle, and Rounded rectangle.

In your code, the different shapes

can have different meanings. Star

for something exciting, or

rectangle for something serious.

To change the shape, use the drop-

down list in the Cloud section of

the Tool Panel. From the menu,

you select Format > Cloud shape.

Color is another way to code

your maps, and Freeplane lets you

change the color of the clouds. The

cloud color changes the

background and outline color of

the cloud. As you have seen in

previous articles, you select colors

from a color dialog. To open the

cloud color dialog, you can click on

the color swatch in the Cloud

section of the Tool Panel. You can

access the cloud color through the

menus, too, at Format > Cloud

shape > Cloud color. Finally, the

main toolbar has an icon for the

cloud color. From the color picker

dialog, you select the color you

want for your cloud background.

You click the OK button to accept

the color.

CONNECTORS

Connectors associate nodes

with relationships other than

parent-child. Connectors are good

for connections between siblings

or nodes in different branches. As

an example, a group of siblings
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defining a repeatable process. A

connector would allow you to loop

the last process back to the first

one. The connector can contain

text to explain the relationship.

Arrows can show the direction of

the connection. You can edit the

line style, color, and thickness to

match your coding system.

The easiest way to create a

node is to right-click on the start

node and drag to the end node. By

default, an arrow points toward

the end node. You can change this,

but it's worth thinking about

before you create the connector.

You can also select the start node

and hold down SHIFT + CTRL while

you drag with the left mouse

button to the end node. Finally,

you can select the start and end

nodes, right-click, and select

Connect from the menu. With two

nodes selected, you can use the

CTRL + L combination to connect

the nodes.

You can connect many nodes at

once. Select the nodes you want to

connect. The last node selected

becomes the focus node. All the

other nodes will point to the focus

node. With the nodes selected, you

right-click and select Connect from

the menu. You can use the CTRL +

L combination, too. All the

selected nodes will connect to the

focus node (last selected).

You can edit a connector by

right-clicking it. A Connector dialog

will open. The dialog lets you

change the style, color, shape,

thickness, and opacity of the

connector. You can add text to the

connect to define the reason for

the connection.

The two Goto buttons let you

select which node is active. You

can switch between the two nodes

at the connectors endpoints.

The Remove Connector button

removes the connector and closes

the connector dialog.

Use the Opacity slider to

increase or decrease the visibility

of the connector. Move the slider

to the left to decrease the

visibility, and move it to the right

to increase the visibility. By

default, the slider is 75% to the

right.

The Connector arrow drop-

down list lets you select the

arrows on the connector. You

select None to create a

relationship without direction.

Draw arrow forward points the

arrow at the endpoint. To point the

arrow at the start point, you select

Draw arrow back. You show a back

and forth relationship by selecting

Draw arrow forward and back. One

of the ways I have used the arrows

is when creating a repeating

process. The process is outlined as

a series of sibling nodes, then the

last sibling points back to the first

sibling. Using this method, I create

a looping or repeating process.

By default, the connector is

drawn as a looping curve. The

Connector shape drop-down list

changes the shape. You select line

to create a straight point-to-point

line. Linear path draws a line with

sharp corners. Finally, you can

Simulate edge. This choice will

create a line that simulates the

edge of the endpoint.

The Connector line drop-down

list sets the type of line. As always,
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you have a choice between solid,

long dash, short dash, dot, and dot-

dash. The line types can become a

part of your code. A dotted line

can show two nodes that are

similar but have no direct

relationship. But a solid line can

show a direct relationship, such as

a node that is a child of two

different nodes. The Width spinner

box sets the width of the line. The

width is a scale value rather than a

unit measurement.

The font setting controls the

font and size of the text used on

the connector. The Font drop-

down list selects the font from the

fonts installed on your PC. The

Font size spinner box sets the size

in points.

With the font set, the

connector has three label

positions. The top text box is for

the Source label. The source label

is the start node of the connector.

The Middle label places text in the

middle of the connector. To place a

label at the endpoint node, enter

your text in the Target label text

box. If you use the source and

target label, you need to set the

connector to show in front of the

nodes. The setting is in the

preferences, Tools > Preferences.

Click on the Appearance tab. In the

Connectors section, you uncheck

the box for Paint connectors

behind nodes.

Click the OK button to close the

Connector dialog.

When you left-click the

connector, you see two adjustment

handles. You drag the handles to

adjust the shape and location of

the connector. Moving the handles

moves the location of the arrows

and labels. This is another method

to prevent the label and node’s

core from blocking each other.

SUMMARY NODES

What do you do when you need

a node that pertains to several

sibling nodes? For example, say

you have a list of fruits and

vegetables as siblings to a node.

You would like to label which ones

are fruits and which ones are

vegetables. You could create a

child node for each of the nodes

stating its food category. But this

seems redundant and time-

consuming.

Enter the summary node. A

summary node groups together a

series of sibling nodes using a curly

bracket. The summary node allows

you to group your fruits and

vegetables using one node for

each group.

To create a summary node,

select the series of sibling nodes.

With the nodes selected, press the

keyboard combination SHIFT + ALT

+ INSERT. The summary node

created looks like any node except

its edge is a curly bracket. Enter

the text of the node and press

ENTER. You can press ENTER again

to create a sibling of the node, or

you can press INSERT to create a

child node. From the summary

node, your map can continue as

you would with any other node.

There are a couple of alternate

methods for creating summary

nodes. After selecting the node

series, you can right-click and

choose New summary node. From

the menus, Edit > New Node > New

summary node creates a summary

node of the selected sibling nodes.

When you create and learn,

associations allow you to build on

previous knowledge. While the

parent-child relationship handles

most associations, sometimes you

need to create others. Freeplane

gives you the tools you need to

create those associations. With the

cloud, you can encompass a group

of nodes, creating a section set off

from the others. You can use

connectors to associate two nodes

that are not parent-child. Finally,

summary nodes allow you to group

sibling nodes together.
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As the saying goes, a picture

paints a thousand words.

Icons and images in your mind map

create a link between the visual

and the language centers of your

brain. This promotes learning and

imagination. When you see the

word fruit, you don't see the

letters in your mind, but you see

images of what fruit are. By using

icons and images in your mind

map, you link to your mind's

natural tendency.

Freeplane includes a set of

useful icons. Although the icons

have recommended meanings, you

can use them in a way that makes

sense to you. Is an exclamation

point a warning or emphasis? It's

up to you and what it triggers in

your mind. As with most things in

mind mapping, the choice is yours.

Freeplane provides a way to

insert your own images into your

maps. To have the images display

in the map, freeplane requires you

save the image to the local hard

drive. The recommended practice

is to have them in the same folder

as your map.

ICONS

Freeplane provides over 90

icons in 1 3 categories and some

specialized progress icons. You

should think about the power of

using icons in your maps. We use

emojis, a special type of icon, every

day to convey emotion in our

messages. Icons can do the same

thing in your maps. Use them as

keys to trigger your mind to know

at a glance what the node is about.

You can display the icon in several

ways, but the most complete

options are through the menu.

The quickest access to the icons

is through the icon side panel. Click

on the expand arrow on the left-

hand side of the

Freeplane window to

expand the icon sidebar.

From the sidebar, you can

select any icon to add it

to the currently selected

node(s) . Using the

keyboard, CTRL + F2

displays a table of all the

standard icons.

In the

sidebar, table,

and menus,

there are three special icons, the

remove icons. The first icon is the

remove first icon, the second is the

remove last icon, and the third is

the remove all icons. In the sidebar

and the table, they are the first

three icons. In the menus, they are

the last menu in Edit > Icons.

The menus under Edit > Icons

gives you the most options and

control of your icons.

Icons from table gives you the

same table the CTRL + F2 keyboard

shortcut does.

Icons by category breaks the

icons into predefined categories.

Keep in mind these categories are

only suggestions. You can let the

icons mean anything you want as

long as it makes sense to you. The

categories follow the same order

as the icons in the sidebar and

table.

The Progress icon (%) menu

contains a special group of icons.



full circle magazine #1 34 21 contents ^

HOWTO - FREEPLANE

While you will find progress donuts

in the icon table, the menu gives

you the ability to automate your

progress. These icons are great for

tasks lists. I use them when

outlining and writing.

The Progress up and Progress

down change the progress icon in

the node. When either is first

selected, the empty donut is

added. If you select Progress up,

the donut increases by 25% until

the progress donut is full. If you

select Progress down, the donut

decreases by 25% until the

progress donut is empty. Once the

progress donut is full, a green

checkmark icon is added to the

node.

The Extended progress options

add a larger progress donut below

the node. The Extended progress

comes in two types, 1 0% and 25%.

The 1 0 % allows for a 1 0 step

process while the 25% only 4.

Selecting the 1 0% or 25% option

adds the process donut below the

node. Once created, you increase

the value by double-clicking the

large progress donut. To decrease

the value CTRL + double-click. The

green checkmark icon will show in

the node when the progress donut

reaches 1 00%. The node will also

show a small progress icon in the

node.

The Show icon hierarchy shows

what icons are attached to any

nodes below it. If the nodes

underneath the node have icons,

the node will display a smaller

version of each of the icons. With a

folded node, you can still know

what icons are being used on the

branch. Should you be looking for

a certain icon based on your code,

you can know you need to unfold

the node.

The Show intersection of child

icons is like Show icon hierarchy

with a twist. The setting only

applies to children of the node. If

all the children have a certain icon,

a smaller version of the icon will

show in the node. This would allow

you to see whether a folded node's

children all contain a certain icon.

The remove icons menu gives

you the Remove first icon, Remove

last icon, and Remove all icons

options.
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IMAGES

Freeplane lets you insert your

own icons and images, too. You can

insert the images as internal or

external to the node. In order for

the images to show in the map,

you must save the images to the

local disk. The accepted formats

are GIF, JPEG/JPG, PNG, and SVG.

In most cases, you will want to edit

your image in an editor and scale it

down to a useful size in your map.

INTERNAL IMAGE

When you insert an internal

image, the image becomes the

node core. The image within the

node core is not scalable, so if you

want a smaller size, you will need

to edit it in advance. To create an

internal image follow the menus

Edit > Node core > Image by choice

or link. Use the folders to browse

to the image location and select it.

Click Open to create the image as

the node core.

EXTERNAL IMAGE

You can add images to the node

details by drag and drop, copy and

paste, and through the menus. In

most cases, your need determines

your method.

When you add an external

image by drag and drop, the

release point determines where

the image is added. Release the

image at the top of the node core,

and the image becomes an

external, scalable image in a new

sibling. But, if you drop the image

with the end highlighted, the

image becomes an external image

of a new child node.

When you use the copy and

paste method, the image becomes

an external image to a new child

node.

To add an image as an external

image of the currently selected

node use the menus Edit > Node

extensions > Add image. Browse to

the image you want to add, select

the image, and click Open.

To scale the external images

hover over the edges of the image.

A box will surround the image.

Click and drag to scale the image

to size. You can only scale the

external images. Internal images

are not scalable.

Icons and images create a

connection between the visual and

the language centers of your brain.

Using icons and images in your

mind maps creates association and

clues about the content of a node.

You can use the existing icon set to

create your own coding system as

well as adding other images as

visual clues.
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I 've mentioned in past articlesabout developing a coding

system for your mind maps.

Implementing a coding system can

seem like an arduous effort. But

Freeplane allows you to create

styles in your maps. Using styles,

you create the style once and use

it as often as needed. You can take

a few minutes to think about and

create the styles you need for your

coding system of colors and icons.

Once you make the styles, you

select them from a dropdown list

to apply them to the nodes.

THE STYLE EDITOR

The style editor is where you

create the styles. It looks like a

scaled-down version of the main

window. To open the editor

through the menus, select Format

> Manage styles > Edit styles. You

can also use the keyboard shortcut

CTRL + F1 1 .

DEFAULT STYLES

The default template comes

with a set of default styles in 3

categories.

PREDEFINED STYLES

The predefined styles are the

system styles. You can't add to or

delete any of the styles in this list.

You can change the appearance of

the styles:

• Default is the style assigned to

new nodes when not using an

automatic layout.

• Details is the styling for the node

details.

• Attributes are user-defined tags.

I ' ll explain attributes in a future

article.

• Note is the style for the note pop-

up that shows when you hover over

a node with notes.

• Floating node is the style for any

floating nodes.

USER DEFINED STYLES

The user defined styles are

where you would add your own

styles. You can add and remove

styles from this list. The default

template has a few styles defined

for you. You can change these or

remove them. The trick is to add

new ones that work in your coding

system.

APPLY LEVEL STYLES

The level styles are a special

group. You can automate the level

styles by selecting one of the

automatic layouts. The first level

style is Root. You can change the

Root style, but you cannot remove

it. The Root is the center node of

all maps. By default, you have 1 1

levels. You can add and remove

levels as fits your needs. You can

change the nodes to fit your

coding system.

MODIFYING STYLES

To change a style, select the

style and use the tool panel on the

right-hand side of the window. This

panel is the same as the panel in
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the main program. You can set the

colors, edge style, and even create

a style with a cloud. The default

floating node has a rectangular

cloud around it. You can add icons

to the styles as well. Open the icon

toolbar by clicking on the sidebar

arrow on the left side of the

window. Or you can open it

through the menus View >

Controls > Icon toolbar. Click an

icon to add it to the selected style.

The display of the styles is a

map itself, but you can't create any

children. You can add and remove

siblings to the user styles and the

level styles. The siblings are not

added in the same way as in the

main window – as detailed below.

ADDING STYLES

When adding a new user

defined style, the style starts as a

copy of an existing style. You can

create a new user defined style

from any of the styles, including

the predefined and the levels.

After selecting the style you want

as your start point, use the menus

Format > Manage styles > New

style from selection. You can also

right-click the style and select New

style from selection. A dialog

prompts you for a name for the

new style. Enter the name and click

the OK button. The new style will

display in the User defined styles

group.

The level styles work a little

differently. When you add a level,

it adds to the end of the levels list.

To add a new level, right-click any

style and select Add level style.

You can add levels through the

menus at Format > Manage styles

> Add level style. When you add a

level by right-clicking, the format

of the right-clicked style is not

copied to the new level. New levels

get the formatting of the default

style.

REMOVE STYLES

You can remove a user defined

style that is no longer needed. Any

nodes the style is applied to will

have the formatting of the style

removed. To remove a user defined

style, right-click the style and

select Remove user defined style.

You can also remove a style by

selecting it and using the menus

Format > Manage styles > Remove

user defined style.

When you remove a level style,

Freeplane removes the highest

numbered level. As with the user

defined styles, any nodes the style

is applied to will have the style

formatting removed. To remove a

level style, use the menus Format >

Manage styles > Remove level

style. Or you can right-click any

style and select Remove level

style.

Once you have finished

changing the styles, click on the

checkmark button to save your

settings. If you want to exit the

edit without saving your changes,

click the X button.

APPLYING STYLES TO

NODES

The easiest way to apply a style

is using the drop-down list on the

main toolbar. The styles display in

the same order as in the style

editor. You can get the same list

using the menus Format > Apply

styles. After selecting the style,

Freeplane applies the style to all

selected nodes. If you select

another style, you remove the

current style and apply the

selected style. It is possible to

apply more than one style through

conditional styles. I will cover

conditional styles in my next

article.

Using level styles works a little

differently. Level styles are applied

by the node's position on the

branch. To apply level styles, use

the menu Format > Automatic

layout. You can apply the levels to

all nodes by selecting for all nodes.

Apply the levels to all nodes but

the ones at the end by selecting

for all non-leaf nodes. By default,

disabled is selected. Disabled

removes all level style formatting.

OTHER STYLE OPTIONS

Sometimes, you will change a

node that has a style applied to it,

and you want to apply those

changes to the style. Use the

menus Format > Manage styles >

Redefine style. This adds the

changes to the style and updates

all nodes with the style. You can

also use the keyboard shortcut ALT

+ R.

At other times, you change a

node and decide you want to

revert back to the formatting of

the style. Use the menus Format >

Manage styles > Remove format to

remove the changes.
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Did you create the best set of

styles ever and want to use it in a

new map? In the new map, use

Format > Manage styles > Copy

map style from... to import the

style from another map. You can

do this with the keyboard shortcut

CTRL + SHIFT + O as well.

STYLE EXAMPLE

When I create a map for

brainstorming a writing project, I

end up with list or outline.

Sometimes, I get started but can't

get back to it for days or weeks. To

keep track of where I 'm at in the

project, I create a TODO and Done

style.

The TODO style has a light red

background and an empty

checkbox icon. I apply this style to

any sections that are not done. For

the Done style, I apply a light

green background and a checked

checkbox icon. When a section is

complete, I switch the style from

TODO to Done.

Styles allow you to design your

coding system by creating a style

once and using it many times.

Through the use of styles, you can

develop and change your coding

system. Next time, I will show you

how to create conditional styles

that allow you to apply more than

one style to a node. I will also show

you how to save a template with all

your styles, so you can use them

over and over again.
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When creating mind maps,

you don't want to spend all

your time formatting individual

nodes. As I showed in part 6, styles

let you format once and use many

times. Sometimes, it's handy to

apply more than one style to a

node. Or you want to apply a style

according to the content, date

created, or the icon applied. Rather

than applying styles manually,

conditional styles apply styles

under predefined conditions.

Conditional style can apply to an

individual node or to an entire

map.

Once you have all you styles

created, you can save them in a

template to use again. While there

is no Save as Template option, it is

possible to save a map in a

template folder.

CREATING CONDITIONAL

STYLES

The first step is to create a style

for the condition to apply. Part 6 of

this series discusses creating

styles. When creating the

conditional style, all the styles are

available to you. For example, you

could create a style that bolds the

text and makes the font bigger

than the default.

There are conditional styles for

individual nodes and the entire

map. The dialogs work and display

the same for both. To open the

‘Manage conditional styles’ dialog,

use the menus Format > Manage

styles > Manage conditional styles

for map (or for node). When you

select ‘Manage conditional styles

for node’, the rules apply to the

selected nodes. ‘Manage

conditional styles for map’ applies

to all nodes in the map.

The dialog shows any defined

conditional styles. If you have not

defined any styles, the list is blank.

There are five buttons down the

right-hand side, two at the bottom,

and four columns.

The New button creates a new

conditional style. It has a filter of

always and the default style. You

can double-click the style to select

another style. The always condition

is unnecessary in the map

conditional styles. But the always

condition allows you to apply many

styles to an individual node or

selected nodes.

The Edit button opens the Filter

Composer dialog. The Filter

Composer allows you to edit the

currently selected condition’s

filter. I ' ll cover the Filter Composer

below.

Clicking the Delete button will

remove the selected conditional

style.

The Up and Down buttons allow

you to reorder the conditional

styles in the order you want them

to trigger. The order can change

the effect the conditional style has

on the node(s) .

Each conditional style has f,

without deleting it, uncheck the

box. The Condition is the filter

selected from the Filter Composer.

To change the filter, click the Edit

button to open the Filter

Composer. The Style is the style to

apply when the condition is met.

You can change the style by

double-clicking the style for a

dropdown list of all the styles. The

last column is the Stop checkbox. If

you check the box, the program

will not apply the conditions after

it in the list. This is one more way

to hold on to a conditional style

without deleting it.

At the bottom of the dialog are

the OK and Cancel buttons. Click

the OK button to accept the

changes and close the dialog. The

Cancel button discards any

changes and closes the dialog.
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THE FILTER COMPOSER

Open the Filter Composer by

clicking on the Edit button. You

build your conditions (or filters) in

the composer. The filters become

the criteria for the conditional

style. The options for creating

these filters are many, and I will

not attempt to cover them all. I will

give examples to show how the

composer works.

At the top of the dialog, you

have three dropdown boxes. These

boxes build a single filter. I like to

think of it as building a sentence.

The first box is the subject of the

filter. From this dropdown, you can

select the different elements of a

node, i .e. core text, details text,

notes. The middle dropdown is the

action of the filter, i .e. equal to,

contains, greater than, less than.

The last dropdown is the qualifier.

This is the text or object, like an

icon, to match. Together the three

button create a complete filter.

There are two checkboxes under

the boxes. Checking Match Case

forces the filter to match the case

of the text in the qualifier box.

Checking Approximate matches

text that is close to the entered

text, e.g. "files" will match with

"flies".

The buttons down the right side

perform actions on the filters

created. The first button is the add

button. It adds the filter created by

the boxes to the list. The second

button will negate the selected

filter. The next two buttons are

activated by selecting more than

one filter. The third button will

combine the selected filters with

an AND command. An AND will

activate the condition only when

both filters are true. The fourth

button combines the two filters

into an OR command. In this case,

the condition will activate when

either filter is true. The fifth

button, split, breaks filters

combined with AND or OR into

individual filters. The sixth button

deletes the selected filters. You

use the seventh button to name a

filter. The last two buttons are

used to move the selected filter up

and down in the list.

There are four command

buttons across the bottom. The OK

button makes the selected filter

the condition of the edited

conditional style. To ignore your

changes click the Cancel button.

You can write the list of filters to a

file using the Save button. After

clicking Save, browse to the

location where you want to save

the file. In the File name text box

enter a name for the file and click

Save. The Open button lets you

open a previously saved filter file.

Browse to the location where the

file was saved, select the file, and

click Open.

EXAMPLES

EXAMPLE 1

The simplest conditional style is

setting a node to have more than

one style. In our example, we will

assign the Topic and Important

styles to a node. Select a node to

apply the styles to. From the style

dropdown in the main toolbar

select the Topic style. Follow the

menus Format > Manage Styles >

Manage conditional styles for
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node. Click the New button. This

creates the default Always

condition. Double-click the Default

style and select the Important

style. Click on OK, and you will see

both styles have been applied to

the node.

EXAMPLE 2

The real power of the

conditional styles is applying a

style under defined conditions.

Create four nodes named One,

Two, Three, and Two More. Follow

the menus Format > Manage Styles

> Manage conditional styles for

map. Click on New. With the new

condition selected, click Edit. In the

first box select Core Text, leave

the second at Contains, and type

"Two" into the third. Click the add

button. With the newly created

filter selected click on the OK

button. From the style dropdown

on the new conditional style,

select the Topic style. Click OK.

You will see the Topic style has

been applied to the nodes with

Two in the core text.

TEMPLATES
Once you have created your

styles and conditional styles, you

will want to save them in a

template. Freeplane doesn't have a

menu option for saving a map as a

template so you will have to

manually save them.

First, you need to know where

the user directory is for your copy

of Freeplane. Use the menus Tools

> Open user directory. Make a note

of the location of the directory.

When you are ready to save your

map as a template, save it in the

Template folder under the user

directory.

The next time you create a new

map, your new template will show

in the dropdown list of the

templates.

Styles, conditional styles, and

templates let you create maps

using your coding system. They

speed up the process of creating

new maps. You may want to create

different templates for different

map types.
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The node core is the focal point

of a node. It's what you see at

first glance. While colors, images,

and icons do a good job of setting

your mapping code, you may need

more than plain text. You could

need it formatted in a certain way.

With the help of the Core Text

section of the Tool Panel, we can

format the core text. We can

display the text as numbers, dates

and times, or mathematical or

chemical formulas. As a bonus, we

can format nodes to create links

between other nodes, files, and

websites.

As a refresher, you find the Tool

Panel on the right side of the main

window. To open it, click View >

Controls > Tool Panel. We will work

with the drop-down box under the

Core Text section.

CORE TEXT FORMATS

The core text formats fall into

three categories, text, numbers,

and dates. By selecting the

different formats, you can force

the core text into a certain format.

TEXT FORMATS

Standard

Standard is the default format.

If you enter a number or a date, it

tries to format the text. For

numbers, Standard defaults to the

#0.#### format (explained

below). If you enter a date,

Standard will format it as M/d/yy

(explained below).

Text

I f you don't want the

autoformatting of standard, you

can select Text. Text displays the

characters as you type them

without any formatting.

LaTex

LaTex is a markup language

used for typesetting technical

documents. LaTex allows you to

create and display mathematical

and chemical formulas. While the

topic of LaTex is beyond the scope

of this article, I will give you an

example and some references.

After setting a node’s format to

LaTex, you can use the LaTex

markup in the core text. If you

enter \frac{x^2}{5}, you get the

fraction shown in the image. When

you start typing, a new window

appears. This is the LaTex editor.

The checkbox ‘Enter confirms’ will

cause the window to close when

checked. If unchecked, you need to

click OK to save your formula.

Unparsed LaTex

Freeplane uses JLaTexMath to

render the LaTex markup. This

module does not recognize all

LaTex markup. But, you may want

to export an entire LaTex

document. The unparsed LaTex

format will mark the node as

LaTex, but will not attempt to

render it. Once you export your

map, Freeplane will pass the

markup to the export engine to

render. If the export engine can

render the LaTex, it will.

For more details on using LaTex

in Freeplane:

http://freeplane.sourceforge.net/

wiki/index.php/LaTeX_in_Freeplan

e

For a short beginner guide to

LaTex:

http://www.docs.is.ed.ac.uk/skills/

documents/3722/3722-201 4.pdf

http://freeplane.sourceforge.net/wiki/index.php/LaTeX_in_Freeplane
http://www.docs.is.ed.ac.uk/skills/documents/3722/3722-2014.pdf
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NUMBER FORMATS

The number formats are

patterns for creating numbers. The

# symbol is a placeholder for a

digit should one exist in that

position. A 0 is a placeholder for a

digit, and if no digit exists, a zero.

In the sample image, the entered

number is show in the core details.

#0.####

This pattern will place a zero

before the decimal point when no

whole number exists. If the fifth

digit after the decimal is 5 or

greater, the fourth digit is rounded

up.

#.00

This pattern will always have

two digits after the decimal point.

If the number does not have the

two digits after the decimal, it

adds two zeros. The pattern

truncates any numbers more than

three digits past the decimal.

#

This pattern is for whole

numbers. Any decimal part of the

number is truncated.

#.##%

This pattern will convert the

number to a percentage,

multiplied by 1 00. If the third

position past the decimal is

greater than 5, it rounds up the

number at the second position.

DATE/TIME FORMATS

The date/time formats allow

you to display the date and time in

various formats. Of course, you can

always enter the date and time as

you want. But using the date/time

formats creates consistency

between all your dates in the map.

M/d/yy

Also known as a short date, this

format displays the month number,

day, and two digit year. It is the

simplest of the date formats.

8/2/1 8

MMM d, yyyy

This format shows the month

abbreviation, the day, and a four

digit year. Aug 2, 201 8.

M/d/yy HH:mm a

This format shows the short

date and the time in 1 2-hour clock

format. 8/2/1 8 1 :59 PM.

yyyy-MM-dd

This format shows the four digit

year, two digit month, and two

digit day. 201 8-08-02.

yyyy-MM-dd HH:mm

This format displays the date as

above and the time in a 24-hour

format. 201 8-08-02 1 3:59.

yyyy-MM-dd'T' HH:mmZ

This format shows the date and

time as per the previous format,

but with the time zone offset from

GMT. 201 8-08-02T1 3:59-0400.

NOTE: The time zone offset for the

U.S. Eastern Standard Time is GMT

- 4 hours.

HH:mm

Shows the time in a 24-hour

clock format. 1 3:59.

HYPERLINKS IN FREEPLANE

Hyperlinks in Freeplane let you

link nodes to other nodes, files,

folders, web pages, and menu

items. Hyperlinks are another way

to show a relationship between

two nodes. When doing research,

links can help by linking to

documents, project folders, or web

pages. Links become digital

references to more information.

Link to Another Node

The first method is the anchor

method. Right-click on the first

node, then Link > Set link anchor.
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Right-click the second node, then

Link > Make link to anchor or Make

link from anchor. To put the link on

the anchor node, select Make link

from anchor. Make link to anchor

puts the link on the second node.

This method works best for nodes

that are far apart on a large map.

The second method is the local

hyperlink method. Select the

nodes you want to link. Right-click

and select Link > Add local

hyperlink. When you link two

nodes this way, the link is from the

first node selected to the second.

External Links

The quickest way to add an

external link is through the drag-

and-drop method. When you drag

and drop on a node, the link to the

external object is added as a child

of the node. You can drag and drop

files, folders, and web URLs. The

name of the file, folder, or URL

becomes the nodes core text. You

can change the core text without

affecting the link.

When you want the link added

to the selected node, use the

menu method. Right-click the

node, then Link > Add hyperlink

(choose). An Open dialog pops up.

Browse to the file or folder you

want to link. Select the file and

click the Open button. You can use

the shortcut keys CTRL + SHIFT +

K. To add a URL to the selected

node, right-click, then Link > Add

or modify hyperlink (type). Paste

the URL into the text box and click

the OK button. You can use the

shortcut CTRL + K, too.

Email Links

To add an email link, right-click

the node, then Link > Add or

modify hyperlink (type). In the text

box, type mailto: and the person's

email address, as in

mailto:person@domain.com. Click

the OK button to save. An

envelope icon is added to the

node. Click on the icon to create a

new email with the email address

in the To: field.

Link to Menu Item

Right-click the node, then Link >

Add hyperlink to menu item. Select

the menu item from the list and

click OK. The icon for the menu

item is added to the node. Clicking

on the icon activates the menu

item.

Edit/Remove Hyperlinks

To edit or remove the hyperlink

on a node, right-click then Link >

Add or modify hyperlink (type). To

remove the link erase the text

from the text box and click the OK

button. If you need to change the

link, change the text in the text

box to make the link correct. Click

the OK button to save.

FINAL THOUGHT ON URLS

One last note on web links. You

can enter the URL as the core text.

Right-click the node, then Link >

Convert link from within the text.

This will use any URL in the text to

create a link. If there are many

URLs in the text, it will convert

only the first one.

The core text formatting lets

you control the way the text

displays in a node. You can use text

options including LaTex for

creating formulas. The number

formats let you control how

numbers display, including

rounding numbers. You can format

dates with the many date/time

formats. Hyperlinks let you

connect nodes, files, folders, menu

items, and web pages.
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When building a map, I often

find it useful to tag or mark

a node. This is especially helpful

when my map is about a project or

a group of projects. Freeplane's

attributes feature does the trick as

it lets you create a property/value

pair. Freeplane keeps track of

these attributes and the values

you assign to them. You can even

lock the list of possible values for

certain attributes. In this article, I

will explore the use of attributes.

ADDING AND EDITING

ATTRIBUTES

There are several methods for

adding and editing attributes. The

most useful being Edit > Node

extensions > Edit attribute in-line.

You can also find Edit attribute in-

line in the right-click menu. Lastly,

you can use the shortcut keys ALT +

F9. If the selected node doesn't

have any attributes, Freeplane

adds a blank pair. The left blank is

for the attribute, and the right

blank is for the value. You can type

in a new attribute name or use the

dropdown arrow to select an

existing one. You can type in a

value in the right blank or press

the ENTER key to get a dropdown

list. The list includes values already

assigned to the attribute.

If there are attributes assigned

to the selected node, you can use

the arrow keys to move around in

the table. You can change the

attribute by using the dropdown

list or by typing a new attribute

name. When editing the value, you

press the ENTER key to get a

dropdown list of assigned values,

or type in a new value.

If you right-click in the table,

you get a context menu. ‘Optimal

width’ scales the width of the table

columns to fit the longest text in

the column. ‘New attribute’ creates

a row for you to add an attribute to

the node. ‘Delete’ removes the

selected attribute from the node.

Up and Down moves you up and

down the rows of attributes. (You

can do the same things with the up

and down arrow keys.) If you right-

click on a value in the table, you

get a context menu that includes

the ability to add hyperlinks. You

can add a link by choosing the file

or typing in the URL/path. You can

add a link to a node, too. You can

use the mailto method as outlined

in Part 8.

Press the ESC (Escape) key to

exit the edit mode or select a

different node.

When you add an attribute to a

node, the menus View > Node

attributes determine whether it

shows. ‘Show selected attributes’

will display only the attributes

tagged as selected. Later, I will

show you how to set the select tag.

To display all attributes below the

node, select ‘Show all attributes’.

‘Hide all attributes’ will show no

attributes. Use the Show icon for

attributes to display the attributes

icon on the node core. If you hover

over a node with attributes, all the

attributes will show in a pop-up.

Another way to add attributes

is through a dialog. Use the menus

Edit > Node extensions > Add

attribute in dialog. The dialog has

two dropdown lists and two

buttons. From the Attribute Name
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dropdown list, you can select an

existing attribute, or you can type

in a new name. The Attribute Value

dropdown list lets you select an

existing value, or you can type in a

new one. Click the OK button to

assign the attribute to the selected

node, or the Cancel button to

discard.

To copy the attributes on a

selected node, use the menus Edit

> Node extensions > Copy

attributes. Select the node you

want to copy the attributes to. To

paste the attributes use the menus

Edit > Node extensions > Pastes

attributes. It is not possible to copy

selected attributes. You are

copying all the attributes of the

node.

ATTRIBUTE MANAGER

The Attribute Manager lets you

add, remove, and edit the

attributes and values for the map.

The manager dialog is a one-

stop/do it all for managing the

attributes in a map. You can

specify which attributes are

selected and which are not. To

open the Attribute Manager, use

the menus Edit > Node extensions

> Attribute manager.

There are four columns across

the top of the dialog: Attributes,

Selected Visible, Restricted Set,

and Edit. The Attribute column

lists the active attributes in the

map. You can check the Selected

Visible column to change how the

attribute shows in the node. If

checked, the attribute will display

below the node. If unchecked, the

attribute shows only when you

hover over the node. This is

dependant on the attribute’s view

settings. Restricted Set locks the

values for that attribute to those

already in the map. Use the Edit

button to change the list of values.

The Edit dialog has a list of the

current values, a text box, and

buttons to add, rename, and

delete. To add a value, type the

new value in the text box and click

the Add button. To rename a value

select the value to change, make

the change, and click the Rename

button. You delete a value by

selecting the value and clicking the

Delete button. Click the Close

button to return to the Attribute

Manager dialog.

Four buttons line the bottom of

the Attribute Manager dialog. The

OK button saves your changes and

closes the dialog. Click the Apply

button to save your settings

without closing the dialog. The

Cancel button closes the dialog

and discards any changes. The

Import Map button opens a dialog

that allows you to import

attributes and values from any

open maps. Select the attributes

and values you want to import and

click the OK button. Click the

Cancel button to close the dialog

without importing any attributes.

The first entry in the manager is

All Attributes. This entry is used to

make changes related to all

attribute names. The other rows

allow you to edit values of specific

attributes. Checking the Selected

Visible makes all attributes visible

under the node. Unchecking makes

all the attributes show only when

the mouse hovers over a node. The

Restricted Set locks the addition of

any attributes except in the

manager. The Edit lets you add and

remove attributes from the

current map. It works the same as

the values dialog, but you are

adding and removing attributes

instead of values.
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FIND AND REPLACE

ATTRIBUTE

In the menus, Edit > Node

extensions > Find and replace

attribute brings up the Extended

attribute editor. The two radio

buttons at the top determine the

nodes affected by your search and

replace queries. You can pick from

Selected nodes and All visible

nodes. The checkbox Skip root

node determines whether to

include the root node in the

search. Two sets of combo boxes

allow you to select or enter

attribute/value pairs. The Add

button applies the top attribute

pair to the indicated nodes. To

remove a certain attribute from

the node, select it in the top pair

and click Remove all values button.

The Remove this value button will

remove only the attribute/value

from the top pair. The Replace with

button will replace the top pair

with the bottom pair. The Close

button closes the dialog.

ATTRIBUTE FROM STYLE

In the style editor, you can add

attributes to a style. When you

assign a node to the style, the

attributes aren't added to the

node. You apply the style

attributes through the menus Edit

> Node extensions > Attribute

from style. This assumes the node

is assigned to a style and the style

has attributes. In the style editor,

you find the attribute options in

the Edit > Node extensions menu.

Remove Attributes

In the menus, Edit > Node

extensions > Remove attributes,

you have options to Remove first,

Remove last, and Remove all

attributes.

TOOL PANEL

In the Tool Panel on the

Calendar and Attributes tab, you

find one more place to add

attributes to nodes. But in the

panel, you get a feature not found

elsewhere, the ability to format

the values of the attributes.

The attribute section is at the

bottom of the tab. The New

attribute button adds an attribute

to the selected node. The Optimal

width works in the same way as it

does in other places. The Value

format will open a list of formats.

You will recognize many of these

from the article on core text

formatting (Part 8). Select a format

to apply to the attribute value. The

format is applied only to the

currently selected value.

The right-click menus are the

same as those when editing the

attributes in-line.

FILTERING AND SEARCHING

NODES BY ATTRIBUTES

In the filter toolbar or the filter

composer, the attribute names

display in the left-hand dropdown

list. The right-hand dropdown list is

available for selecting defined

values. Select the comparison

operator from the middle

dropdown list. All comparison

operations consider the data type

of the values (text, date, time,

number). The status bar shows the

type of the selected value.

Attributes are a great way to

tag and identify nodes for a certain

purpose. You can add attributes in-

line or through the Attribute

manager. In the Tool Panel, you

have an option to format the

values on the Calendar and

Attributes tab.
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I find myself using Freeplane totrack my writing, tasks, and

projects. Once a map gets to a

certain size, it's hard to see the

whole map at once. I could zoom

out until I can see the entire

mindmap, but I can't read the text

or identify the icons. I need the

ability to remind myself about that

node on the other side of the map.

You know, the one about the

article that has a deadline

tomorrow. Lucky for me, Freeplane

has a time management feature

that lets me add dates and

reminders. Now, I get things done

on time.

TIME MANAGEMENT

The time management features

create reminders and add dates to

nodes and attributes. To access the

main time management dialog, use

the menus Tools > Manage time.

The Manage time dialog will

appear on the screen. The dialog

allows you to have it open and still

work on your map. This means you

can leave the dialog open when

you need to access it often.

Three monthly calendars line

the top of the dialog. The center

calendar controls the other two.

The first time you open the dialog,

it defaults to the current date. The

clock at the bottom defaults to the

present time. You can use the

month dropdown list to select

another month, and the year

number box to change the year.

The left calendar is the month

before the center calendar, and the

right calendar is the month after

the center calendar. The left and

right calendars are for reference

only. You can't change or select

within them. The numbers to the

left of each calendar are the weeks

of the year.

There are three controls related

to the date. The Reset calendar

button changes the middle

calendar and the clock to the

computer date and time. The clock

works off a 24-hour clock, no AM

or PM. The next two controls deal

with inserting the date/time into

the map. The dropdown list selects

the format you want for your

date/time. The ‘Insert date in

Selection’ button places the

date/time using the selected

format into the map. You can

insert the date/time to the core

text or an attribute value. I will

show you later the quickest way

I 've found for adding the date into

an attribute value.

The last button on the first row

is ‘Edit script’. Clicking this button

brings up the script editor window.

After writing the code, click the OK

button to attach the script to the

reminder. The commands execute

when the reminder activates.

Creating scripts is a topic for

another article. For now, know this

is the place where you can attach a

script to a reminder.

The next row of buttons deals

with reminders. Reminders are the



full circle magazine #1 39 23 contents ^

HOWTO - FREEPLANE

key to the time management

system. When a reminder is set to

a node, you get an alert when the

reminder becomes active. How it

alerts you depends on the settings

in the preferences.

The ‘Reminder at this date’

button creates a reminder in the

selected nodes for the date and

time in the middle calendar. Select

the date, adjust the time to when

you want the reminder, and click

the button. If you hover over a

node with a reminder, the

reminder will display in the popup

text. Freeplane adds a clock icon to

the node, too.

The ‘Remind later’ button, the

numeric spinner box, and the

dropdown list work together to

create a reminder that is offset

from the current date/time in the

middle calendar. The dropdown list

is a list of periods: minutes, hours,

days, weeks, months, and years.

Enter the count for the period in

the numeric spinner box. When

you click the ‘Remind later’ button,

Freeplane adds a reminder offset

for the period based on the

date/time in the middle calendar.

‘Remove reminder’ erases the

reminder from the current node.

Use this button to acknowledge a

reminder alert, too.

The Close button closes the

dialog.

TASKS MANAGEMENT

After creating many tasks, it's

nice to have a place to organize

and work with them. Freeplane

provides you with a dialog where

you can work with your reminders.

Open the dialog through the

menus Tools > Manage tasks.

The dialog shows a list of the

tasks in the map. The dialog

contains 7 columns:

• Date -- the day/time for the

reminder.

• Text -- the core text of the

reminder's node.

• Icons -- icons attached to the

node.

• Created -- the day/time the node

was created.

• Modified -- the last day/time the

node was changed.

• Details -- the text of the node

details.

• Notes -- the text of the node

notes.

You can sort the list on any of

the columns by clicking the column

name. The first click will sort the

list in ascending order. The second

click will sort the list in descending

order. Further clicks will toggle

between ascending and

descending.

The Find text box can help you

narrow down a long list. As you

type, the reminders will shrink to

only those containing the text. If

you check the Match case

checkbox, Freeplane will take the

upper and lower cases into

account. The Regular expression

checkbox lets you include regular

expressions in your search.

Replace lets you replace the

text in the Find field with the

version in the replace field. For

example, you want to replace all

occurrences of Menu with Menus.

You would type Menu in the Find

text box and Menus in the Replace

text box. When you click the

Replace all button, Freeplane will

replace all occurrences of Menu

with Menus. After selecting

specific results, you can click the

Replace selected button to do the

replacement only in those nodes.

The Replace text box also has a

Regular expressions checkbox.

The Export selected nodes

button will export the selected

nodes to a new map. You can use

this to create a new file based on

specific reminders. The Goto

button will close the dialog and
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highlight the selected node. The

Close button exits the dialog.

With the menus Tools > Remove

reminder, you can remove a

reminder without opening the

Manage time dialog.

TOOL PANEL

In the tool panel, there is a tab

for Calendar and Attributes. There

you find a monthly calendar that

behaves like the center calendar in

the Manage time dialog. All the

buttons and dropdowns work the

same way as they do in the dialog.

Having them in the tool panel

makes for quick access when you

need to add a date or set a

reminder.

I find the tool panel as the

quickest way to add a date to an

attribute value. Open the Calendar

and Attributes tab in the tool

panel. Set the date and time and

select the format. In the attribute

section, click New attribute. Select

an existing attribute name from

the dropdown or type in a new

name. Select the value cell and

press Enter. Click the Insert Date in

Selection button. Press the Enter

key again to save the value.

PREFERENCES

In the Freeplane preferences

are settings to control the

behavior of reminders. The

settings are located in the menus

Tools > Preferences. You find the

Reminder options on the Behavior

tab. The Reminder blink checkbox

blinks the reminder icon when the

reminder activates. To show a

reminder popup window, check the

‘Reminders show notification

popups’ checkbox. The Reminder

delay sets how long a reminder

delays when you click the ‘Reinder

me later’ button in the reminder

popup. Set the number for the

period and the period to delay. The

time periods are ms (milliseconds) ,

seconds, minutes, hours, days, and

weeks.

If you have the setting checked

for the notification popups, a

popup window displays for a

reminder when it activates. The

popup gives you four options:

• ‘Go to reminder’ closes the popup

and moves to the node with the

reminder.

• ‘Remove reminder’ acknowledges

the reminder and removes it. This

is like a ‘done’ option.

• If you need to delay the reminder,

click the Remind me later button.

The reminder is suspended for the

amount of time defined in the

preferences.

• The Close button exits the popup

and does nothing.

Through the date and reminder

options, you can manage your

projects in Freeplane. Along with

the attributes, you can use

Freeplane as a project

management platform. In the next

article, I will walk you through

setting up a project template that

you can expand.
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Wehave covered enough

Freeplane features that we

can build a useful template. For

our example, I 'm showing you a

simple project management

system. I 've mentioned before I

use Freeplane to outline and

manage my projects. The template

will allow for the management of

many jobs. We will create a set of

attributes and styles to make the

system work for us. Once we finish

the template, we will implement

the model.

We'll build our model using the

standard template file. Use the

menus File > New Map and select

the standard.mm file.

ATTRIBUTES

First, we will create the

attributes. The attribute manager

allows us to set up everything we

need. You open the manager using

the menus Edit > Node extensions

> Attribute manager. We'll create

the attribute names by clicking on

the edit icon for the ‘All attributes’

row. Add these attributes through

the list dialog: Status, Start, and

Due. When you add to the list, a

row is created in the manager

window. After adding all the

names, click the Close button.

For the attribute Status, we will

add default values. Select the edit

icon for the Status row and add the

values: On Hold, Working, Pending,

and Complete. Click the Close

button and check the Restrict set

checkbox. Restricting the set

prevents mistakes when entering

the project's status.

Select the checkboxes to make

all the attributes visible. Click the

OK button to close the manager.

STYLES

Styles are the visual character

of the mind map. Through them,

we assign colors, icons, and

attributes to differentiate nodes.

We will create six for our template.

Each style defines a different

purpose on the map.

GETTING STARTED

Use the shortcut keys CTRL +

F1 1 to open the Style editor. Select

the Default style and change the

Node Shape to Bubble. Delete all

the default User Defined Styles. To

delete a style, right-click it and

select ‘Remove user defined style’.

PROJECT

The project is a to- level node

defining the project title. We'll

assign the attributes Status, Start,

and Due to the style. A node

assigned to Project will become

the parent node for each project.

So, we want Project to stand out

among the others.

Right-click the Default style and

select New style from selection. In

the text box that pops up, enter

the name Project and click OK. The

new Project node shows under in

the User defined styles node.

Under the Color of whole core

section of the Tool Panel, click on

the Text swatch. From the color

pallet, pick one of the darker blues

for the text color. Scroll down to

the Font for whole core section,

and set the Font size to 1 8. Check

the bold box. The Project style is

big and bold and catches the eye.

We want to add some attributes

to the Project style. To add the

first attribute, use the menus Edit

> Node extensions > Edit

attributes in-line. A new attribute

row is inserted into the node. Use

the dropdown on the left to select

Status. Double-click the value for
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the Status and choose Pending,

then add the Start and Due

attributes using the right-click

menu. Leave the values for the last

two blank.

Finally, we'll crown it with the

mind-map icon. When I think of a

job, I think of all the things that go

into it. Often, you can make a

project a map on its own. For me,

it's the best choice from an image.

Select the icon from the Styles icon

sidebar.

PRIORITY LEVELS

We'll create three priority

styles, high, medium, and low.

These styles are meant to show

the importance of an item in the

project. As we step down through

each of the priorities, the visual

impact decreases. Use the Default

node as the starting point for each

level by right-clicking Default and

selecting New style from selection.

For Priority High, bold the font

and make the background color

red. Add the exclamation point for

an icon. The Priority Medium is

simpler than Priority High. Make

the font italic and the background

color yellow. For the Priority Low,

we just give it a dull gray

background.

TODO AND DONE

I can't create a template

without my standard ToDo and

Done. In this case, we will keep

them simple. For ToDO, add the

empty checkbox, and for Done,

add the checked box. These two

styles we'll use for tasks. By

keeping the text plain, we can

easily mix them with the priority

styles. For both, use the Default

style as the starting point.

SAVE TEMPLATE

We are finished with the

template. We need to save our

work. Click the menus File > Save

Map. At the top of the save dialog,

you'll see a drop-down box. From

the drop-down, select the option

‘User templates’ to move the

location to your template folder.

Name the file Projects.mm and

click the Save button. Once the file

is saved, you can close it.

IMPLEMENTATION

Now, we need to use our new

template. The menus File > New

map brings up the Select template

dialog. From the drop-down list,

click on the Project.mm file and

click the OK button. Freeplane

creates a map using the template.

Rename the root node to My

Projects. Pressing the Insert key

will create a child node. Name the

node Project 1 . From the main

toolbar, use the styles drop-down

list to select the Project style. Use

the menus Edit > Node extensions

> Attributes from style to add the

Status, Start, and Due fields below

the node.

Use the Insert key to create a

child node for the project and

name it Tasks. Create several

children for Tasks, naming them

Task 1 , Task 2, etc. Select all the

tasks nodes and assign the ToDo

style to them.

Now, let's make one of the

tasks a high priority. After

selecting one of the nodes, follow

the menus Format > Manage styles

> Manage conditional styles for

node. Click the new Button to

create an Always condition. From

the Style drop-down list, pick High

Priority. Click the OK button, and

the style's format is added to the

node. Repeat these steps for the

other tasks, assigning them

different priorities.

You can click into the Start and

Due attributes below the project

node and type in dates according

to your local format.

We created a simple template

without many bells and whistles;

however, it is a starting point for

more advanced features. Using

conditional formatting, you could

tag currently active projects. Play

with the template, expand it, and

make it your own. After all, making

it your own is the core principle of

mind mapping.
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Whenever possible in my

tutorials, I give you the

keyboard shortcuts for the

commands. I do this because I 'm

lazy, and if a hotkey is available, I 'm

not going to follow the menus

(frankly, it's a lot of typing too).

You probably noticed most

commands don't have a shortcut.

My second choice is the right-click

context menu. If there are no

shortcut or context-menu options,

you have to use the menus. Well,

maybe not.

Freeplane lets you create

shortcuts. Freeplane includes a

special toolbar for managing the

shortcuts assigned to the Function

keys (F keys) , and gives you a

reference and buttons to click. The

function keys sit across the top of

your QWERTY keyboard, F1 -F1 2.

Hotkeys are key combinations, and

they can include the F keys.

DEFAULT FUNCTION KEYS

The function keys let you

activate a command quickly. By

default, Freeplane assigns five of

the twelve keys to frequently used

commands:

• F1 opens the Freeplane tutorial

map. The map is read-only but

contains a guide to most of the

software's features. I have used it

as a jump-off spot for many of my

articles.

• F2 edits the node core inline. I use

this key almost exclusively when

creating a map. I like to keep my

hands on the keyboard as much as

possible without having to reach

for the mouse. Reaching for the

mouse could break my

concentration just enough for me

to forget what I was going to type.

Yeah, I know, I 'm old-school weird.

• F3 edits the node details inline.

Again, my hands on the keyboard,

broken concentration, old brain

losing stuff faster than I can type

it. Stop laughing. It's a severe

problem.

• F5 runs a presentation. We

haven't discussed presentations

yet. I hope to write about this

someday. I managed to get it on

my to-do list before it floated off

into the ether.

• F1 1 switches to full-screen mode.

It's a way to avoid the distraction

of the GUI . With all those buttons

to push and menus to click and

explore, one might forget what it

was they wanted to type. F1 1 is

especially great for brainstorming

when you aren't worried about

formatting but just getting ideas

down.

THE F-BAR

Freeplane has a special toolbar

called the F-Bar. To open the F-Bar,

follow the menus View > Controls

> F-Bar. The taskbar shows you

what commands are assigned to

the function keys, F1 -F1 2.

If you want to run the

command, you can press the

associated function key, or you can

click the button. You can press the

SHIFT key to see the hotkeys set

for the SHIFT + F? combination.

The same is true for the ALT, CTRL,

and other command key

combinations. In each case, you can

click on the button or press the key

combination.

Freeplane labels unassigned

buttons as <no action>. Clicking

any of these <no action> buttons

gives you with a window asking

you to select the menu you want to

assign to the shortcut. Click

through the menus to the item you

want to attach to the hotkey. The

text from the menu item becomes

the text for the F-key button.
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CREATE NEW HOTKEYS

You can create other hotkeys

than those related to function

keys. To assign a new combination,

use the menus Tools > Assign hot

key. You are prompted to select

the menu for the hotkey, or you

can click Cancel to stop the

process. Once you choose the

menu item, Freeplane prompts you

to enter the key combination.

Enter the keystroke using the

keyboard and click OK. If the

hotkey is assigned to another

command, the program asks you to

confirm replacement of the

current assignment. Click Yes to

change the shortcut, or click the

No to leave the hotkey as

previously assigned.

To remove a hotkey, select

Tools > Assign hot key and use the

Clear button to remove the

shortcut assignment. Clicking OK

will remove the hotkey, and

clicking Cancel will leave things

unchanged.

Once you have your shortcuts

the way you want them, you

should save them. Use the menus

Tools > Hot key presets > Save hot

key set. Freeplane prompts you for

a name. To save the current

hotkeys, enter a name and click

OK, or click Cancel to stop the

process.

To load a saved preset, use the

menus Tools > Hot key presets >

Load, and select the name of the

preset set you want to use. Saving

the presets allows you to have

different sets of shortcuts for a

variety of map types.

ICON HOTKEYS

You can assign shortcuts to

icons. They work only in the Icon

Table dialog. By default, the

hotkey for the icon table is CTRL +

F2. Once the table is open,

pressing the key(s) for the icon

adds the icon to the selected

node(s) .

To assign keys to the icons,

press the CTRL + (comma) to open

the Preferences dialog. You find

the icon settings on the Keystrokes

tab. You see many hotkeys already

assigned. Assign the shortcut by

clicking the box beside the icon.

Enter the key combination and

click OK. Be careful in here as the

program will let you assign the

same key to more than one image.

KEY REFERENCE

In creating so many shortcuts,

you might forget what you

assigned to what. Help > Key

reference displays a list of the

menu items and the hotkeys

associated with them. The list

includes any shortcuts you have

created.
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BUT WHAT SHOULD I
CREATE HOTKEYS FOR?

Well, it depends on you. If you

find yourself using a menu item

often and no hotkey is assigned,

you should attach a hotkey to it. I

like using the function keys for my

most used commands. After that,

use key combinations that make

some sense to you. For example, if

I were assigning a shortcut to

Assign hot key, I would use the

CTRL + H key combo. The choice is

up to you. Like everything in mind

mapping, make the program work

for you and the way you do things.
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I recently took two months offfrom writing articles, and I

focused on other things in my life.

When I returned to writing again, I

discovered Freeplane had gone

through a couple of updates. When

Freeplane went from 1 .6 to 1 .7,

bug fixes and cosmetic changes

were made, and the interface got

new features added. This month,

I 'm looking at the editor changes

made by the programmers. As of

this writing, the latest stable

version is 1 .7.5, and you can

download it at

https://www.freeplane.org/wiki/in

dex.php/Home.

The installation is pretty

straightforward, and updates your

current version of Freeplane. If you

choose to stay with the 1 .6 release,

the features I discuss this month

will not work.

NODE ALIASES

You can reference and link

nodes together through features

already in place, but when a node

is on the other side of the map,

making these links becomes

cumbersome. Node aliases make

referencing important nodes

easier. Freeplane allows two types

of aliases, regular and global. A

global alias is directly accessible,

while a regular one is not.

To create an alias, select the

node you want and follow the

menus Edit > Node properties >

Set node alias. The Alias dialog

pops up. In the text box, type a

name for the alias. The name must

contain at least one letter but can

have numbers and underscores

too. Spaces are not allowed. Check

the Globally accessible checkbox to

make the alias global. The OK

button saves the settings, and

Cancel closes the dialog without

any changes.

ALIAS AS A FILTER

Now that you have an alias, you

want to use it. You can filter a

search or conditional style based

on a filter. When creating a

condition, you select "alias" from

the "criteria" drop-down. The drop-

down list for the "object" is a list of

aliases in the current map.

Since aliases work as a tag for

the node, you can have nodes with

the same alias name. You can use

this as a type descriptor to quickly

filter a specific type of node. When

filtering by an alias, Freeplane

doesn't care whether the alias is

global or not.

NODE PATHS

Now that you have a node alias,

you will want to use it for

something. In the new release of

Freeplane, you can create a path to

any node in the map, and the

quickest path leads to a global

alias. Aliases can help to make the

path to a wordy node easier to

compile.

For the examples, I 'm using the

branch shown top right.

My examples of paths are as

internal links, but node paths work

https://www.freeplane.org/wiki/index.php/Home
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in scripts using the node.at

function, too.

When using paths as links, the

pattern is #at(path). To add a link

to a node, use the quick keys

CTRL+K. You enter the #at() path

into the text box.

Example 1 :
#at(/'Elmer'/'This...'/'Team'
/'Tina')

The path in this example starts

at the root node. The root is

denoted by the backslash (/) at the

beginning. The backslash also

separates the individual nodes.

Elmer in single quotes points to

the first node from the root. The

next node in the path looks for a

node that starts with the word

This. The ellipses (...) shows the

node has more characters after the

word quoted. The last two nodes in

the path demonstrate referencing

a node by text. If you click on the

link for a node assigned this path,

Tina becomes the active node.

Example 2:
#at(:~Elmer)

This example shows the power

of global aliases. Since Elmer is a

global alias, we can jump directly

to it. The tilde (~) is used to

reference aliases, but when a

global alias starts the path the

colon (:) is added. This path jumps

straight to the Elmer node.

Example 3a:
#at(:~Elmer/'This...'/'Team')

Here we use the global alias

Elmer to start a path to another

node. The path will activate the

Team node. But there is a better

way. The node "This is a long node"

has an alias of LongNode. We can

change the path to example 3b.

Example 3b:
#at(:~Elmer/~LongNode/'Team')

By directly addressing the alias,

we don't take any chance on

another node containing the text

"This" getting in our way.

Example 4:
#at(:~Elmer/~LongNode/'Team'/
~3

In the path, we continue the

previous one a bit further. The ~3

at the end selects the third child of

the node Team, Paul.

These are just a few examples

of the use of aliases and node

paths. For a more detailed

description of node paths, you can

click on the link:

https://sourceforge.net/p/freeplan

e/discussion/758437/thread/9505

30ab/. On the forum page,

developer Dimitry Polivaev

provides more details.

OTHER FEATURES

I f you press an unassigned

function key, Freeplane presents a

dialog to create a shortcut to a

menu. If you don't want this

feature, you can check the box

‘Don't ask me again’, and Freeplane

will ignore the pressing of

unassigned function keys. Besides

the checkbox, you can change this

option in Tools > Preferences. The

keystrokes tab has a checkbox

labeled ‘Ignore Unassigned F-keys’.

Check the box to ignore the key

presses, and uncheck it to get the

assignment dialog.

Sometimes, when you create a

filter, you want to flip the results,

meaning you want everything that

doesn't match the conditions. Now,

you can. In both the search and the

conditional formatting dialog, you

have a checkbox tagged ‘Deny’.

Checking the box creates a filter

with everything that doesn't match

the filter's condition.

In previous versions, if you

wanted to export a branch, you

had to copy it to a new map. Now,

you can export without creating a

new file. After activating the node,

select the menus File > Export

branch. A ‘save file’ dialog pops up.

Browse to the location where you

want to create the file. After you

choose the file type and give it a

name, click the Save button.

Finally, the documentation and

tutorial maps have been updated

to reflect the latest release. A big

"Thank you" from me to the

programmers for this one. The

updated information makes my

work a little easier.

And there you have it, These

are just some of the features and

updates found in Freeplane 1 .7.

For a full list, see the tutorial map

included with the update.

Elmer Perry is a technical support
rep for an international keyless
access company. He enjoys writing,
woodworking, and technology. He
lives in Leicester, NC with his wife.
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So far, I have demonstrated how

Freeplane works as everything

from a simple brainstorming tool

to a project management tool. The

software takes you beyond the

basic idea of mind mapping and

expands into a tool for many jobs.

Today, we will expand

Freeplane a little further. Packaged

with Freeplane is the note editing

utility Simple HTML Editor. The

developers Ulrich Hilger and

Dimitry Polivaev designed the

editor, and they made an editor

that's easy to use. You can use the

editor to change and create node

text, node details, and node notes.

The node notes seem the natural

place to use the editor, but,

sometimes, you will want to

format your node text and node

details more extensively.

To open the editor to edit the

node text, you use the key

combination ALT + ENTER. For the

node details, use the combination

CTRL + F3, and when using the

editor for node notes, CTRL + >,

which requires you to hold the

shift key.

THE TOOLBAR

The toolbar for the Simple

HTML Editor looks like many you'd

see in any text editor. You have

buttons for printing, undo and

redo, cut, copy, paste, and search.

You have dropdown boxes for the

font and font size. You can change

the format of the text with bold,

italic, underline, and text color

buttons, or remove all formatting

with the click of a button. Format

your paragraphs as left, right, or

center aligned, and create bulleted

or numbered lists. Most of what

you need to do in the editor you

can do from the toolbar.

Two of the toolbar icons

generate option dialogs, search,

and text color. The search dialog

allows you to search, or search and

replace. The options let you match

case, words, search from the start,

and search up or down. The text

color dialog enables you to select a

color using swatches, HSV, HSL,

RGB, or CMYK.

THE MENUS

EDIT MENU

The Edit menu has the usual

copy, paste, print, and find and

replace options. The dialog for find

and replace is the same as the one

on the toolbar.

The menu includes the ability to

create underlined links like the

ones you find on web pages. To
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create an underlined link, highlight

the text you want to turn into a

hyperlink. From the menus, select

Edit > Add or modify hyperlink

(type). In the dialog, enter or paste

the URL for the link and click OK.

To link to a file on your PC's hard

drive, use the Add hyperlink

(choose) menu option, browse to

the document, and click Open.

FORMAT MENU

The Format menu has options

for styling the text you highlight in

the editor. You will find all the

standard character and paragraph

style selections, but a few of the

choices generate dialogs which

allow you to fine-tune the look of

your text.

The Font option opens the

Format Font dialog. You can select

the font family you want to use,

the size, the style, the effects, and

the color. The preview text shows

you how your selection will look.

The dialog is your one-stop shop

for character formatting.

The Paragraph option lets you

format how paragraphs display.

You can control the alignment,

vertical alignment, and

indentation. The indentation

applies only to the first line. The

paragraph has two sets of margins,

inner and outer. Think about a

rectangle surrounding the text of a

paragraph. The outer margin is

padding outside the box, and the

inner margin is padding inside the

box. If you select a background

color for the paragraph, you can

see the edges of the rectangle,

and the effect of the inner and

outer margins. The Font tab of the

Paragraph style dialog is the same

as the font dialog with the

addition of the background color.

The Color options display the

same dialog discussed in the

toolbar section and gives you some

default color choices, too. You can

choose from red, green, blue, and

black. The ‘remove color’ removes

the color selection.

The List option lets you

customize the display of lists. From

the Type dropdown, you can select

the numbering style or bullet type.

You can position the numbers and

bullets so that they are on the

inside or outside of the paragraph

margins. You can control the

indentation of all four sides of the

list item.

TABLE MENU

The table menu helps you

create tables in your node text,

details, or notes. When you click on
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the Table item, you get prompted

for the number of columns. Enter

how many columns you want and

click the OK button. You can edit

and format each cell individually,

moving between the cells using

the tab key. If you press tab while

in the last column, the editor

creates a new row. The columns

will autowrap as you type the text.

In the menu, you have tools to

insert, delete, and add rows and

columns. All the formatting

options work inside the table cells,

allowing you to create a visually

pleasing table.

HELP MENU

The Help menu has an About

simple HTML item that displays the

GNU license for the utility.

VIEW TABS

At the bottom of the Simply

HTML window are two tabs. The

tabs give you a different view of

the text in the editor, and

depending on your knowledge of

HTML, you can customize the

information even further.

At its roots, the text in the

editor is HTML. You can view the

actual HTML using the HTML Code

view. The editor uses an embedded

stylesheet and inline styles to

markup the text. Switching back

and forth between the views, I got

a sense for how it all worked. I did

add some HTML to see that

directly editing the HTML works. In

HTML Code view, many of the

formatting tools are disabled.

Most users will want to stick

with the Layout view, which shows

you the formatted text. In this

view, you can use all the tools to

format your text. You will work

here most of the time. Save the

HTML Code view for when you

need to tweak something.

THE BUTTONS

When you open the editor to

write a node note, the Simple

HTML opens docked to the bottom

of the program window. However,

when you edit node text or details,

the editor opens in a window. You

will see buttons at the bottom of

the window. For the node details

you see OK and Cancel buttons,

but with the node text you also get

a Split button.

The OK button saves the text as

formatted and returns to the map.

The Cancel button ignores any

changes and returns to the map.

The Split button divides the node

into two nodes at the location of

the cursor. With a node of "One

Two," if you place the cursor

between the two words and click

on Split, Freeplane will create two

nodes, "One" and "Two."

The Simple HTML Editor is a

tool built into Freeplane for

editing the text of node text,

details, and notes. At its roots, the

layout is HTML, but you don't have

to know HTML to use it as the

Layout view works like a mini word

processor.

Elmer Perry is a technical support
rep for an international keyless
access company. He enjoys writing,
woodworking, and technology. He
lives in Leicester, NC with his wife.
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With every article or story I

write, I use Freeplane for my

research and my outline. My last

article on the Simple HTML editor

prompted me to explore the

possibility of creating the draft

copy of a document in Freeplane.

The node text becomes the header

for each section, and the notes

become the text body. I can then

export the draft branch of the map

to a document for editing. The

advantage is having the Outline in

front of me while I work. The draft

of this article was written using

this method, and in it, I 'm sharing

my experiment with you.

SETTING UP THE MAP

Everything started with setting

up a mind map for my project. I

wasn't overly concerned with the

formatting of the map but

concentrated more on the layout. I

titled the root node the same as

the planned title for the article,

Freeplane Part 1 5. I know,

attention-getting stuff. Fancy titles

are saved for the fiction side of

writing. I created four branches

from the root, Brainstorming,

Research, Outline, and Draft. Let

me explain to you how I used each

of the branches.

BRAINSTORM

Brainstorming is where the

whole process began. I start by

creating nodes of my ideas about

the article. What did I want to

accomplish? How did I think it

would work? What didn't I know?

Brainstorming is best done without

holding yourself back and noting

all the ideas even if you think you

will never use them. I was mostly

interested in how all the different

parts would show in the final

document. I had a good idea that

the node text would show as

headers and the notes as each

section body. What I didn't know is

how the node details would fall

into the mix. I didn't plan to use

node details, but going beyond can

result in something useful and is

the main idea behind the

brainstorm session.

RESEARCH

Research is where I gathered

data for the article. I did look on

the web for what I wanted to do,

but I didn't find anything. So I went

with the experimental method.

Under the research node, I created

three experiments to test my

theories. I found the node text and

notes worked as I had expected:

the node text as a header with the

notes text below. I discovered a
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node with details gets the details

sandwiched between the node

text and notes. Any sub-nodes are

placed in order under their

parent's details and notes with

their own details and notes. With

my questions answered, I was

ready to create an outline.

OUTLINE

The Outline (bottom right) is

where I fleshed out the details of

the information I want to use in

the article. From this, I generated

the draft nodes. I rarely remove

things from a map. Instead, I will

mark them out with an X icon or

strikethrough font. I don't want to

delete it should I decide to go back

to it. The Outline grows and

changes as I work on the draft. It's

always in flux. If there are menus,

shortcuts, or step-by-step

instructions, they get detailed in

the Outline. In some cases, the

outline nodes have very little

detail because not much is needed.

I have a good idea of what needs

saying, but I will always add nodes,

details, and notes for things I don't

want to forget.

DRAFT OUTLINE

I prepared the draft outline to

write the article. Pulling from the

Outline node, I selected the

essential points and added them

to the Draft branch. These become

the headers, so I tried to not go

too deep with the sublevels. Two

or three levels should work in most

cases. I rarely go beyond two levels

because I feel anything beyond

that creates excessive sectioning

of the text. I want the article to

become more than just an outline
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with an explanation for each point.

It's an article, not a bulleted

presentation. Presentations in

Freeplane are a subject for another

day.

CREATING THE DRAFT

Now, the writing can begin. I

started by selecting the draft

outline node and opening the

notes editor with the shortcut

CTRL + >. I typed the introduction

to this article. I moved on to each

node under the draft outline, and,

in the Simple HTML editor, wrote

the text for that section. I liked

being able to reference the

Outline where I had made notes

and comments about the content

to include.

Another nice thing about

writing in this manner is not having

to write sections in order. If I

wanted, I could start at the end.

It's easy to jump from one node to

the other to add, change, or

remove text from that section. I

found myself having an idea about

one of the different parts while I

was working, and I 'd simply click on

the node and make the change.

The Simple HTML editor doesn't

have many distractions, so I wrote

with very few stops because a

grammar checker caught

something in my sentence

structure. I saved that for the

editing process. The process also

made it easy to move things

around. If I moved one section

before another, the text for that

section moved with the node. I

found this quicker than the old

standard cut and paste of a

traditional text editor.

While working in the editor, you

can format your text as well. I

usually don't. Most of the

formatting is up to the magazine

editor anyway. It's pretty easy to

over-format a document. I try not

to. However, if you are creating a

manuscript for work or school,

then you can't go wrong by editing

as prescribed by your work style

sheet or teachers guidelines.

EXPORTING THE DRAFT

Once the writing is complete, I

wanted to export the draft outline

to a document. I changed the name

of the Draft Outline node to the

title I wanted for the article. I

selected the draft outline node

and used the menus File > Export
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Branches. A Save File dialog

popped up. I browsed to the folder

where I wanted to save the

document. By default, the root

node text is used for the document

name. You can type a new one in

the name text box, but I decided

the name was good enough. You

will want to select the type of

document you're exporting to. I

used the plain text format so I

could quickly move it from my

editing software to Google Docs

without too much fuss, but other

types are available, including

Microsoft Word and the Open

Document Format.

CLEANING UP THE EXPORTED

DOCUMENT

Depending on the format type

you exported to, you might need

to format the headers and change

the spacing. When I did a text

export to ODT, I found the ‘before’

spacing on the headers wasn't to

my liking. I also removed the

Conclusion node text as I find it a

nuisance header, but it made sense

for the draft outline. You might

have other node text headers you

want to remove. If I were writing a

story rather than an article, I 'd

probably remove the node text

headers unless they somehow fit

the story.

For my plain text format, the

export put numeric outline tags on

all the header. I removed these.

Also, before each note, I had to

remove the text "NOTE:."

Otherwise, once I imported the

document into my Grammar editor,

I was ready to begin my editing

process.

Overall, I enjoyed writing my

article draft in this manner.

Usually, I 'm distracted by grammar

alerts, word counts, and other bells

and whistles related to a full

function editor. This method was a

nice change. I worried the word

count would fall short of my usual

work but discovered I actually

wrote more. For drafting a

document, I found this method

surprisingly refreshing. Will I use it

again? I ' ll have to try it a couple

more times to see whether it

actually grows on me, but the

prospects are good.


